Technical issue - downloads aren’t available offline


#1

Hello, hope it’s ok to ask this question… I’m new to using this app and I love it! It’s my favorite resource to date :slight_smile: I only have one problem, i’ve only got to challenge 3 as my downloads aren’t available if I don’t have wifi. I’m currently traveling around South America so spend a lot of time without wifi. I’ve tried deleting and re-downloading the app but it’s showing the same problem…any advise/hints would be greatly appreciated:)


#2

I don’t use the Spanish app much since it’s only on iOS so far, but I do use the android ssiw app. Once I have pressed on the cloud symbol and the lesson is downloaded I can listen without wifi. I just tried downloading a lesson in Spanish and then turned my wifi off. It seems to be working fine for me.
Hopefully someone technical will be along in a bit with some way of making it work for you.
In the meantime, what I do to get Spanish on my android phone may work for you. I download the lessons from the website rather than the app, then just play them in my phone’s music player. I’ve created a playlist to keep them together and in the right order.


#3

That sounds odd - might be a settings thing - they’re certainly meant to be available permanently once they’re downloaded - @lewie might be able to ask some sensible questions here… :slight_smile:


#4

I assume that we’re talking about the iOS app here. The app itself doesn’t distinguish whether you are using Wifi or not. But there are a couple of things that I can think of to check:

  1. Is cellular data disabled? (Settings app -> Cellular -> Cellular Data - there’s a slider switch that enables/disables it)

  2. Is cellular data disabled for the app? (same screen … scroll nearly to the end to “SaySomethingInWelsh” - there’s a similar slider switch)

Both of those should be ON to enable downloads without Wifi. Be sure that you’ve got a good international data plan in place first, though, or it could get expensive!


#5

Thank you @lewie the problem isn’t downloading them, it’s accessing them once I leave wifi…but I hear you, that makes no sense…I agree, maybe it’s just my phone, it is old and I’ve recommended the app to a friend and she had no problems. Like I said, I tried, deleting, re downloading the app and and challenges and rebooting the phone…it doesn’t make sense. :slight_smile: i’ve attached a screen shot of the message I get when I try to use the app without wifi (having previously downloaded numerous challenges). But @emmamartindale gave me a good option, so I will try that. Thank you all for your time! :slight_smile: aran too. :slight_smile:


#6

Looking at the screen shot I noticed the small airplane icon in the top left… maybe you accidentally turned the phone to “flight mode”? That could explain the described behavior, as one of the features of flight mode is to disable all data connections.


#7

Ah … thanks for the clarification!

I haven’t had a chance to verify this, but next time you have Wifi, start up the app (if necessary close it). Then it will be able to download the course catalog. After that, it should work fine regardless of whether you have a connection or not.

For reference - what version of iOS are you running?


#8

@Hendrik and @lewie thanks for the response and your time. I put it on airplane mode to simulate leaving wifi. My issue is that i have downloaded challenges but when i leave wifi i get that error message in the screenshot. So to be clear, i do not have an issue downloading challenges, only accessing them once i leave wifi. I’m running ios11.4. It’s a strange issue i know, my phone has been buggy with other apps too, it’s almost 4 years old which makes it ancient! :wink: But i think we can leave it there as Emma gave me a solution. Thank you all for your time, I really appreciate it :blush:


#9

Since I knew I would not have internet connection easily I downloaded all Welsh lessons on my iPod before leaving for vacation.

I just tapped on each challenge cloud icon until it turned into a play button. Now they’re working fine offline. (I don’t know if Spanish app works the same way though).

My iOS is 9.3.5


#10

I hate to “leave it there” because others may run into the same issue :wink:

I just reproduced your problem by installing the app fresh and blocking the network. I got the “Unable to obtain …” error. Then I unblocked the network and hit “Try again” (in that dialog shown above). The catalog loaded, and the app was able to function normally. Then I quit the app, blocked the network again, and fired up the app. It worked, and I was able to play the already downloaded lessons.

The app is able to retrieve the course catalog from the local cache of saved web pages, so it normally it works just fine without a network connection. I’d suggest trying to fire up the app the next time you have Wifi to give it a chance to download a copy of the course catalog. If necessary, go to the Settings tab, tap and hold the top banner, and select “Refresh”.

If you continue to see the problem, then I wonder if the problem is that your phone isn’t keeping a saved copy of the course catalog. This might happen if your memory is nearly full - very possible if you’ve had the phone for a while.


#11

@lewie you’ve solved it! I have very limited memory on my phone! But i tried the refresh trick and that seems to have worked, even if I close the app. Brilliant, thank you! :blush: