SSi Forum

Lessons not downloading on android


#1

I’ve searched everywhere, uninstalled, reinstalled, uninstalled, reinstalled, logged out, logged in, logged out, logged in, over and over, but cannot get lessons to download onto my Samsung 9. the app used to work perfectly but I haven’t used it in over a year and I was hoping to start again. Searching the forums I only found really old answers but not to this specific question. Can anyone help??

After a long wait I get some message about connectivity problems both over Wi-Fi and on 4G


IOS app
#2

Check in your Google Play Store and phone settings for download/play ootions. You may have them in disagreement…


#3

Hello,@chirojoe!

Let’s ask @jamesmahoney if he has any tips and a solution for you.

In the meantime (as a simple user like you) I can tell I only get a message about connectivity when I try to download a lesson while not connected to a Wi-Fi, since my phone is configured to download only on Wi-Fi. But since you said it happens on both to you, I’m afraid it’s not the case.

So if you click on a lesson, the little cloud icon turns into “download queued” and then nothing happens?

By the way…now the free available lessons are 1 to 15 of Level 1. maybe you’re a subscriber so this doesn’t matter, and I guess on the App you don’t see the lessons you can’t download at all, but I’m not sure so just in case!


#4

It’s frustrating isn’t it because you’ve done all the simple things properly. Did Gisella’s solution work by verifying you are on Wifi? If not, and before James replies, he will ask you to go to Settings tab on the app and turn on “debugging” or “logging” to capture data for diagnosis.

Until your problem is resolved are you able to take the lessons over your laptop/desktop?


#5

Thanks everyone for the replies so far. I was on the road most of the day so I haven’t tried anything further. I am able to do the lessons from the phone browser, but The app is so much easier to navigate if I could get it to work. After 4 years I’m only on lesson 13 so I’m still in the free section, haha.
Since I’m newydd dechrau dysgu-ing– once again I thought I’d start over :grin:Hopefullyy tomorrow I’ll be able to investigate and I’ll let you know.


#6

@jamesmahoney will be able to shed some light on this when he’s around :slight_smile:


#7

…also view this thread


App issue
#8

It looks like this thread hasn’t been touched in awhile, but I’m running into the same issue. The app worked perfectly on my Pixel but when I put it onto my Pixel 3, I can’t get the lessons to download. I’m logged in (have a subscription), connected to wi-fi, and when I click on a lesson to download, it says it’s download for a few minutes then gives me an error telling me there’s a network connectivity problem. I tried deleting and reinstalling and toggling the switch to allow downloading over data but nothing has worked. I generally do the lessons in the car on my commute so not having the app work on my phone means no practice for me recently. @chirojoe, did you ever get your app to work?

I’ve also posted about this over on IOS app, even though that’s about the iOS app.


#9

…And as soon as I posted this, after hours of fiddling with the app and phone, I did… something?.. and it started working. I’ve decided it must be magic and I’m not going to question it, just enjoy. Sorry to spam folks!