SSi Forum

SSiW iOS app just updated


#1

A new version of the iOS app has just been released. The main difference is that the new version supports streaming. So, you no longer have to download each lesson before you can start playing it.

You can still manage downloading the audio if you need to - for example if you know that you’ll be somewhere without internet access - just go to the “Levels” tab and do a long press on a lesson number - it will give you a little menu with an option to download (or it’s already downloaded, it’ll give you the option to delete the downloaded file to save space).

There’s also a new option (see the Settings tab) to auto-advance to the next lesson (it’s turned off by default).

Ah … and I almost forgot - the advanced content works in this version! Look for it on the Levels tab by swiping past Level 3.

It’s been in beta test for a while, but I still expect some fresh hiccups to show up - so don’t hesitate to give a shout here if you have any problems with the updated app!


App issue
#2

Thank you for your hard work @lewie. I have been using your IOS beta daily for some time and it works beautifully for me.

Rich :slight_smile:


#3

How absolutely awesome, @lewie - utter hero :heart:


#4

I wish I’d found this before going on my travels to where data/battery charge gets used up in a flash… I was so busy trying to show people the app on my travels, while on buses and trains, andnow I know I can get more control of already downloaded stuff, that is just brilliant @lewie


#5

It might be just because I have a particularly old iPad Mini, but when I tried to use the app yesterday I had a few problems. I could see that it was a new version - Advanced Content readily available - but the app kept shutting down the iPad, as if it didn’t recognise something was playing. I had to keep tapping the screen to keep it active. Also, the progress bar didn’t move smoothly across, starting off OK, but then stopping and when I restarted the app, it jumped across to where it should have been. I tried some of the challenges and old course material and had the same issue with everything. I haven’t had this problem before, and I do use the app fairly regularly.


#6

Do you mean audio stops every time it goes stand-by/screen not active?

Is this another way to describe what happens to you?

Because in this case, that was happening to me in the beta version, but just to me, and @lewie couldn’t recreate the effect even if he wanted!

Then do you mean audio does weird jumps after pause (or if you go “rewind” o ffwd)?
For this I deleted all the downloaded files I had on the iPod, downloaded them all again and it has worked fine ever since.


#7

@dee - what version of iOS is your old iPad mini running?


#8

iOS 9.3.5


#9

Yes, that’s it :slight_smile:


#10

Same as my iPod! (it was months ago since we talked about this with @lewie, so I’m writing it here so it’s easy to find/compare).
But I’m afraid there’s very few people still using it besides us! :sweat_smile:


#11

Thanks for confirming. I’ve got an old iPhone 4s around here somewhere running iOS 9… I’ll test it out and with luck will be able to get it fixed!


#12

Brilliant, diolch yn fawr! It’s a reliable little thing but I’m finding more and more that I can’t install things as they’re not compatible and it won’t let me upgrade the OS.


#13

Thanks for the update.
It might sound like a daft question but I am signed up to the 6 month course and have been using the app as it’s more handy than downloading lessons onto my phone. It’s been working for level 1 but it tells me that level 2 is premium content and requires me to subscribe in order to get access. Is there any way around this at all?


#14

Great question … as far as I know, it should work … but let’s check with @kinetic.


#15

A basic question I know, but are you logged in with the same email address? Just something to check. Your 6 Month registration looks fine in the database to me.


#16

Dee you’ve solved it! Diolch! Technology does not agree with me unfortunately. It seems to be working now and I’ve managed to download a few of the lessons. Diolch eto pawb


#17

Just checking the updated app and the player seems to work fine with streaming and all links such as vocabulary lists, speed and volume all work fine. I’m using the latest iOS (12.2 according to my settings) on iPhone X.


#18

I’ve found the likely culprit, but I never did find an older device still running iOS 9, so haven’t been able to test it yet for real.

Look for a new beta to come out soon and let me know if that does the trick.


#19

@lewie this email came through to admin today:

Hi admin team,
I have tried to use the SSIW app today (iPhone xs max, latest iOS update installed) and it thinks that I’m no longer a subscriber - it won’t let me look at content - it’s asking me to subscribe. My last payment was taken on time and on the website version it’s working fine.
Please can this be fixed?
Thanks very much

Kate

(as you can see from the photo below 21-25 are locked. I tried installing and reinstalling the app but now I’ve lost all my progress and it still thinks I’m not a subscriber!)


#20

I remember this happening in the beta version. But since I don’t use the iPod so much, I thought it was my fault.

I’m sure I did something that got it to work again, without needing help from @lewie or anyone, and it has been working ever since, but I can’t remember what I did!

However…this might be how I ended up re-subscribing by mistake (as I had told you about a month ago).

So I’d suggest everybody to be careful with clicks, because that would give Dee and SSiW staff quite an overload of work to do!!! :scream: