SSi Forum

SSiW iOS app just updated


#21

I’m the Kate from the email above…now I’ve seen this thread Ive got it working- I didn’t spot that if I held my finger on the session I want it would offer to download it! Brilliant touch that!
I’ve just just been back on to double check and it’s working perfectly to just click and play now too - it’s not asking me to subscribe for the content anymore, it’s all working fine. No idea what’s changed in the last hour but it’s working!
Thanks all


#22

Thanks, Kate! I think there’s clearly something going on with the transition from the old version of the app to the new … just haven’t nailed down where the mischief is. But glad to hear that things are working now.

So … I think what I’d suggest if people have troubles with the new version of the app. First, try quitting the app and re-starting (here’s a quick ref on how to do that, since it’s different in different versions of iOS: https://www.lifewire.com/quit-apps-on-iphone-2000287). If that doesn’t help, then try manually downloading a lesson as described earlier on this thread.

If none of those work, then just give a shout here, of course!


#23

Touching back to this topic - in particular for @dee. I’ve released a new beta that seems to fix the problem of the app stopping audio playback when the screen goes dark. Are you game to try the beta before I release it? Here’s the thread with instructions on installing the beta. for reference.


#24

Sorry @lewie. I was working in Cardiff for a few days, so just home and getting round to this. I’ll have a go at installing the beta on my old iPad tomorrow and see how it goes.


#25

OK, just installed it with Testflight and had a test. The issue with the audio stopping when the screen went dark is now resolved, and it appears to be working fine. Diolch yn fawr @lewie!


Unable to Access Challenge 19
#26

Thanks Lewie, that was most helpful. I switched on auto-advance, then logged out then back on again and when I returned to the app, all the levels have downloaded at my request and are working as they should.

Thanks also to Dee for a swift email response with helpful advice.

Malcolm


#27

Many thanks to Dee for the prompt response and directing me to this thread.

I’m on an iPhone, I tried the above steps and was still asked to subscribe. The only way I was able to get around it was to delete the app and download it again - it seems to be working fine now.


#28

Jenny - glad you have things working now! But, for the sake of knowing more specifically what didn’t work - did you try quitting the app before finally deleting it? (https://www.lifewire.com/quit-apps-on-iphone-2000287)


#29

Hi Lewie,

Yes, I did try force-quitting the app before I deleted it, but was still getting the message asking me to subscribe when I tried to download the lessons. I’m on an iPhone XR running iOS 12.2 if that’s any help


#30

Again, just so that I can try to triangulate - did you double-check that you were signed-in with the correct account before deleting the app?


#31

It’s all working alright now.

Just one thing I noticed today, and thought I’d just let you know, just in case: I had accidentally logged out of the app the other day. i tried to log in this morning, and when I had to write the password it kept on doing that little shake just like when you write the wrong password.
I kinda went crazy for a few minutes, checked elsewhere if I had forgotten it, checked upper case, lower case, even copied and pasted with no luck until I realized wifi was off. It just wasn’t able to connect, but it didn’t tell me, ah!

So of course it’s me the dumb one :smiley: - but the fact that it accepts the user name alright (so apparently everything’s fine until then) and then it behaves just like when the password is wrong is a bit confusing.

It all works out in the end, but just thought I’d tell you @lewie


#32

Funny you mention this, because I too had been locked out—as I thought, but once I hit the ‘Subscribe Now’ button it acknowledged me. Then I had to go to the button on the top LH of the screen to access the courses—as usual, no worries there.

It does seem a bit confusing.

I do have another technical question too—should I be able to download on iOS devices, specifically my iPhone and iPad? I have been hitting the MP3 button or text area for it, and the lessons do ‘stream’, but don’t save as they would on an MO3 Player. Why I ask is that I am soon going to be spending hours on a plane and trains—it would be wonderful if I could store some ‘challenges’ to work through during the journey.

Thanks in advance for any help and suggestions you can offer.

Mari


#33

In the iOS app, you can manage downloading the mp3s by going to the “Levels” tab, then to download a lesson, do a long-press on a lesson that you want to download - and up will pop a little menu saying “download” - tap that, and the mp3 will download (and the little cloud icon will go away for that lesson). Now you are ready to do that lesson (and others you download) on the plane.


#34

You are a gem Lewie—that’s brilliant, and great timing! I owe you a beer—or latte, whatever your pleasure.

Diolch yn fawr iawn,
Marilyn


#35

Hi again, sorry to be a pest, but I thought I had the downloading problem cracked… not yet it seems.

I am being blocked or redirected. The App on my iPhone and iPad keeps saying I am wanting to access ‘premium content’ so need to subscribe—which I do already. I hit subscribe anyway and it recognizes me, but then sends me into a different format, not the one one I start with on the App that I think would let me download on my iOS devices.

I can stream lessons OK, but am still not able to download. In the new window I am redirected to on the courses, if I press and hold a lesson number there are 4 options, none of which is ‘download’.

I seem to be missing something, but confess to being a Ludite—still had a rotary phone until a couple of years ago, which impressed folk who thought we were being ‘terribly retro’. :joy:

Thank you again for any advice. Maybe it is the way my subscription is ‘grandmothered’ in the system that needs to be adjusted so I am not repeatedly asked to subscribe.

Hwyl,
Marilyn


#36

I’m guessing the problem is that you are not logged in when you are in the app. This is separate from logging in when using the web browser.

Go back to the SSi app, and tap the Settings tab - if there’s a “Log in” button near the top, tap it, and enter your e-mail and password.

If that wasn’t the problem, just shout!


#37

That’s done the trick–thank you so much Lewie.

Now I’m away to the races, so to speak–downloading even as I type.

Bless you!!!
Marilyn


#38

@lewie this came through as an email to Admin:

Helo :blush:
It pains me to say but the new app doesn’t work at all well on my phone which is fully updated
I constantly have to log in and log out, I’m sometimes without levels, have only been able to access the first 6mins of challenge 19, level 3. Sometimes the levels load, sometimes they don’t.
Can you help me please?
Diolch
Ali x

Are you able to help her please?